CRAN Package Check Results for Package AIPW

Last updated on 2024-06-13 10:48:47 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.6.3.2 7.85 73.60 81.45 OK
r-devel-linux-x86_64-debian-gcc 0.6.3.2 0.34 1.72 2.06 ERROR
r-devel-linux-x86_64-fedora-clang 0.6.3.2 104.48 NOTE
r-devel-linux-x86_64-fedora-gcc 0.6.3.2 109.20 NOTE
r-devel-windows-x86_64 0.6.3.2 9.00 75.00 84.00 OK
r-patched-linux-x86_64 0.6.3.2 8.46 76.64 85.10 OK
r-release-linux-x86_64 0.6.3.2 5.10 70.59 75.69 OK
r-release-macos-arm64 0.6.3.2 36.00 OK
r-release-macos-x86_64 0.6.3.2 60.00 OK
r-release-windows-x86_64 0.6.3.2 7.00 82.00 89.00 OK
r-oldrel-macos-arm64 0.6.3.2 37.00 OK
r-oldrel-macos-x86_64 0.6.3.2 58.00 OK
r-oldrel-windows-x86_64 0.6.3.2 8.00 84.00 92.00 OK

Check Details

Version: 0.6.3.2
Check: package dependencies
Result: ERROR Package required but not available: ‘ggplot2’ Package suggested but not available for checking: ‘testthat’ See section ‘The DESCRIPTION file’ in the ‘Writing R Extensions’ manual. Flavor: r-devel-linux-x86_64-debian-gcc

Version: 0.6.3.2
Check: dependencies in R code
Result: NOTE Namespaces in Imports field not imported from: ‘Rsolnp’ ‘SuperLearner’ ‘future.apply’ ‘ggplot2’ ‘progressr’ ‘stats’ ‘utils’ All declared Imports should be used. Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc