CRAN Package Check Results for Maintainer ‘Jim Duggan <jim.duggan at nuigalway.ie>’

Last updated on 2021-08-05 22:55:40 CEST.

Package ERROR NOTE OK
aimsir17 1 13
pysd2r 1 12 1

Package aimsir17

Current CRAN status: ERROR: 1, OK: 13

Version: 0.0.2
Check: package dependencies
Result: ERROR
    Package required but not available: 'tibble'
    
    Package suggested but not available for checking: 'dplyr'
    
    See section 'The DESCRIPTION file' in the 'Writing R Extensions'
    manual.
Flavor: r-devel-windows-x86_64-gcc10-UCRT

Package pysd2r

Current CRAN status: ERROR: 1, NOTE: 12, OK: 1

Version: 0.1.0
Check: LazyData
Result: NOTE
     'LazyData' is specified without a 'data' directory
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-devel-windows-x86_64, r-patched-linux-x86_64, r-patched-solaris-x86, r-release-linux-x86_64, r-release-macos-arm64, r-release-macos-x86_64, r-release-windows-ix86+x86_64

Version: 0.1.0
Check: dependencies in R code
Result: NOTE
    Namespace in Imports field not imported from: ‘knitr’
     All declared Imports should be used.
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-patched-solaris-x86, r-release-macos-arm64, r-release-macos-x86_64, r-oldrel-macos-x86_64

Version: 0.1.0
Check: package dependencies
Result: ERROR
    Package required but not available: 'tibble'
    
    Packages suggested but not available for checking:
     'dplyr', 'ggplot2', 'testthat'
    
    See section 'The DESCRIPTION file' in the 'Writing R Extensions'
    manual.
Flavor: r-devel-windows-x86_64-gcc10-UCRT