CRAN Package Check Results for Maintainer ‘Max Kuhn <max at rstudio.com>’

Last updated on 2021-07-27 22:54:35 CEST.

Package ERROR WARN NOTE OK
AmesHousing 14
baguette 14
corrr 1 11 2
dials 14
discrim 1 6 7
embed 12 2
finetune 1 7 6
modeldata 7 7
modeldb 14
parsnip 1 13
plsmod 1 11 2
poissonreg 14
recipes 1 13
rules 4 8 2
tidymodels 7 7
tidyposterior 14
tidypredict 14
tune 1 1 12
usemodels 13 1
workflowsets 1 13

Package AmesHousing

Current CRAN status: OK: 14

Package baguette

Current CRAN status: OK: 14

Package corrr

Current CRAN status: WARN: 1, NOTE: 11, OK: 2

Version: 0.4.3
Check: LazyData
Result: NOTE
     'LazyData' is specified without a 'data' directory
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-devel-windows-x86_64, r-devel-windows-x86_64-gcc10-UCRT, r-patched-linux-x86_64, r-patched-solaris-x86, r-release-linux-x86_64, r-release-macos-arm64, r-release-macos-x86_64, r-release-windows-ix86+x86_64

Version: 0.4.3
Check: re-building of vignette outputs
Result: WARN
    Error(s) in re-building vignettes:
    --- re-building ‘databases.Rmd’ using rmarkdown
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) not available. Falling back to R Markdown v1.
    Quitting from lines 45-48 (databases.Rmd)
    Error: processing vignette 'databases.Rmd' failed with diagnostics:
    polygon edge not found
    --- failed re-building ‘databases.Rmd’
    
    --- re-building ‘using-corrr.Rmd’ using rmarkdown
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) not available. Falling back to R Markdown v1.
    Warning in grid.Call(C_stringMetric, as.graphicsAnnot(x$label)) :
     no font could be found for family "Arial"
    Warning in grid.Call(C_stringMetric, as.graphicsAnnot(x$label)) :
     no font could be found for family "Arial"
    Warning in grid.Call(C_stringMetric, as.graphicsAnnot(x$label)) :
     no font could be found for family "Arial"
    Warning in grid.Call(C_stringMetric, as.graphicsAnnot(x$label)) :
     no font could be found for family "Arial"
    Warning in grid.Call(C_stringMetric, as.graphicsAnnot(x$label)) :
     no font could be found for family "Arial"
    Warning in grid.Call(C_stringMetric, as.graphicsAnnot(x$label)) :
     no font could be found for family "Arial"
    Warning in grid.Call(C_stringMetric, as.graphicsAnnot(x$label)) :
     no font could be found for family "Arial"
    Warning in grid.Call(C_stringMetric, as.graphicsAnnot(x$label)) :
     no font could be found for family "Arial"
    Warning in grid.Call(C_stringMetric, as.graphicsAnnot(x$label)) :
     no font could be found for family "Arial"
    Warning in grid.Call(C_stringMetric, as.graphicsAnnot(x$label)) :
     no font could be found for family "Arial"
    Warning in grid.Call(C_stringMetric, as.graphicsAnnot(x$label)) :
     no font could be found for family "Arial"
    Warning in grid.Call(C_stringMetric, as.graphicsAnnot(x$label)) :
     no font could be found for family "Arial"
    Warning in grid.Call(C_stringMetric, as.graphicsAnnot(x$label)) :
     no font could be found for family "Arial"
    Warning in grid.Call(C_stringMetric, as.graphicsAnnot(x$label)) :
     no font could be found for family "Arial"
    Warning in grid.Call(C_stringMetric, as.graphicsAnnot(x$label)) :
     no font could be found for family "Arial"
    Warning in grid.Call(C_stringMetric, as.graphicsAnnot(x$label)) :
     no font could be found for family "Arial"
    Warning in grid.Call(C_stringMetric, as.graphicsAnnot(x$label)) :
     no font could be found for family "Arial"
    Warning in grid.Call(C_stringMetric, as.graphicsAnnot(x$label)) :
     no font could be found for family "Arial"
    Warning in grid.Call(C_stringMetric, as.graphicsAnnot(x$label)) :
     no font could be found for family "Arial"
    Warning in grid.Call(C_stringMetric, as.graphicsAnnot(x$label)) :
     no font could be found for family "Arial"
    Warning in grid.Call(C_stringMetric, as.graphicsAnnot(x$label)) :
     no font could be found for family "Arial"
    Warning in grid.Call(C_stringMetric, as.graphicsAnnot(x$label)) :
     no font could be found for family "Arial"
    Warning in grid.Call(C_stringMetric, as.graphicsAnnot(x$label)) :
     no font could be found for family "Arial"
    Warning in grid.Call(C_stringMetric, as.graphicsAnnot(x$label)) :
     no font could be found for family "Arial"
    Warning in grid.Call(C_stringMetric, as.graphicsAnnot(x$label)) :
     no font could be found for family "Arial"
    Warning in grid.Call(C_stringMetric, as.graphicsAnnot(x$label)) :
     no font could be found for family "Arial"
    Warning in grid.Call(C_stringMetric, as.graphicsAnnot(x$label)) :
     no font could be found for family "Arial"
    Warning in grid.Call(C_stringMetric, as.graphicsAnnot(x$label)) :
     no font could be found for family "Arial"
    Warning in grid.Call(C_textBounds, as.graphicsAnnot(x$label), x$x, x$y, :
     no font could be found for family "Arial"
    Warning in grid.Call(C_textBounds, as.graphicsAnnot(x$label), x$x, x$y, :
     no font could be found for family "Arial"
    Quitting from lines 106-110 (using-corrr.Rmd)
    Error: processing vignette 'using-corrr.Rmd' failed with diagnostics:
    polygon edge not found
    --- failed re-building ‘using-corrr.Rmd’
    
    SUMMARY: processing the following files failed:
     ‘databases.Rmd’ ‘using-corrr.Rmd’
    
    Error: Vignette re-building failed.
    Execution halted
Flavor: r-release-macos-arm64

Package dials

Current CRAN status: OK: 14

Package discrim

Current CRAN status: ERROR: 1, NOTE: 6, OK: 7

Version: 0.1.3
Check: dependencies in R code
Result: NOTE
    Namespace in Imports field not imported from: ‘utils’
     All declared Imports should be used.
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-patched-solaris-x86, r-release-macos-arm64, r-release-macos-x86_64, r-oldrel-macos-x86_64

Version: 0.1.2
Check: tests
Result: ERROR
     Running 'spelling.R' [0s]
     Running 'testthat.R' [22s]
    Running the tests in 'tests/testthat.R' failed.
    Complete output:
     > library(testthat)
     > library(discrim)
     Loading required package: parsnip
     >
     > test_check("discrim")
     == Failed tests ================================================================
     -- Failure (test-flexible.R:106:3): api errors ---------------------------------
     `discrim_flexible() %>% set_engine("monday")` threw an error with unexpected message.
     Expected match: "Available engines are: 'earth'"
     Actual message: "Engine 'monday' is not supported for `discrim_flexible()`. See `show_engines('discrim_flexible')`."
     Backtrace:
     x
     1. +-testthat::expect_error(...) test-flexible.R:106:2
     2. | \-testthat:::quasi_capture(...)
     3. | +-testthat:::.capture(...)
     4. | | \-base::withCallingHandlers(...)
     5. | \-rlang::eval_bare(quo_get_expr(.quo), quo_get_env(.quo))
     6. +-discrim_flexible() %>% set_engine("monday")
     7. \-parsnip::set_engine(., "monday")
     8. \-parsnip:::check_spec_mode_engine_val(...)
     -- Failure (test-linear-fda.R:107:3): api errors -------------------------------
     `discrim_linear() %>% set_engine("monday")` threw an error with unexpected message.
     Expected match: "Available engines are: 'MASS', 'mda'"
     Actual message: "Engine 'monday' is not supported for `discrim_linear()`. See `show_engines('discrim_linear')`."
     Backtrace:
     x
     1. +-testthat::expect_error(...) test-linear-fda.R:107:2
     2. | \-testthat:::quasi_capture(...)
     3. | +-testthat:::.capture(...)
     4. | | \-base::withCallingHandlers(...)
     5. | \-rlang::eval_bare(quo_get_expr(.quo), quo_get_env(.quo))
     6. +-discrim_linear() %>% set_engine("monday")
     7. \-parsnip::set_engine(., "monday")
     8. \-parsnip:::check_spec_mode_engine_val(...)
     -- Failure (test-linear-lda.R:132:3): api errors -------------------------------
     `discrim_linear() %>% set_engine("lda")` threw an error with unexpected message.
     Expected match: "Available engines are: 'MASS', 'mda'"
     Actual message: "Engine 'lda' is not supported for `discrim_linear()`. See `show_engines('discrim_linear')`."
     Backtrace:
     x
     1. +-testthat::expect_error(...) test-linear-lda.R:132:2
     2. | \-testthat:::quasi_capture(...)
     3. | +-testthat:::.capture(...)
     4. | | \-base::withCallingHandlers(...)
     5. | \-rlang::eval_bare(quo_get_expr(.quo), quo_get_env(.quo))
     6. +-discrim_linear() %>% set_engine("lda")
     7. \-parsnip::set_engine(., "lda")
     8. \-parsnip:::check_spec_mode_engine_val(...)
     -- Failure (test-naive-Bayes.R:190:3): api errors ------------------------------
     `naive_Bayes() %>% set_engine("lda")` threw an error with unexpected message.
     Expected match: "Available engines are: 'klaR', 'naivebayes'"
     Actual message: "Engine 'lda' is not supported for `naive_Bayes()`. See `show_engines('naive_Bayes')`."
     Backtrace:
     x
     1. +-testthat::expect_error(naive_Bayes() %>% set_engine("lda"), regexp = "Available engines are: 'klaR', 'naivebayes'") test-naive-Bayes.R:190:2
     2. | \-testthat:::quasi_capture(...)
     3. | +-testthat:::.capture(...)
     4. | | \-base::withCallingHandlers(...)
     5. | \-rlang::eval_bare(quo_get_expr(.quo), quo_get_env(.quo))
     6. +-naive_Bayes() %>% set_engine("lda")
     7. \-parsnip::set_engine(., "lda")
     8. \-parsnip:::check_spec_mode_engine_val(...)
     -- Failure (test-naive-Bayes_naivebayes.R:192:3): api errors -------------------
     `naive_Bayes() %>% set_engine("lda")` threw an error with unexpected message.
     Expected match: "Available engines are: 'klaR', 'naivebayes'"
     Actual message: "Engine 'lda' is not supported for `naive_Bayes()`. See `show_engines('naive_Bayes')`."
     Backtrace:
     x
     1. +-testthat::expect_error(naive_Bayes() %>% set_engine("lda"), "Available engines are: 'klaR', 'naivebayes'") test-naive-Bayes_naivebayes.R:192:2
     2. | \-testthat:::quasi_capture(...)
     3. | +-testthat:::.capture(...)
     4. | | \-base::withCallingHandlers(...)
     5. | \-rlang::eval_bare(quo_get_expr(.quo), quo_get_env(.quo))
     6. +-naive_Bayes() %>% set_engine("lda")
     7. \-parsnip::set_engine(., "lda")
     8. \-parsnip:::check_spec_mode_engine_val(...)
     -- Failure (test-quad-qda.R:143:3): api errors ---------------------------------
     `discrim_quad() %>% set_engine("qda")` threw an error with unexpected message.
     Expected match: "Available engines are: 'MASS'"
     Actual message: "Engine 'qda' is not supported for `discrim_quad()`. See `show_engines('discrim_quad')`."
     Backtrace:
     x
     1. +-testthat::expect_error(...) test-quad-qda.R:143:2
     2. | \-testthat:::quasi_capture(...)
     3. | +-testthat:::.capture(...)
     4. | | \-base::withCallingHandlers(...)
     5. | \-rlang::eval_bare(quo_get_expr(.quo), quo_get_env(.quo))
     6. +-discrim_quad() %>% set_engine("qda")
     7. \-parsnip::set_engine(., "qda")
     8. \-parsnip:::check_spec_mode_engine_val(...)
     -- Failure (test-rda.R:108:3): api errors --------------------------------------
     `discrim_regularized() %>% set_engine("monday")` threw an error with unexpected message.
     Expected match: "Available engines are: 'klaR'"
     Actual message: "Engine 'monday' is not supported for `discrim_regularized()`. See `show_engines('discrim_regularized')`."
     Backtrace:
     x
     1. +-testthat::expect_error(...) test-rda.R:108:2
     2. | \-testthat:::quasi_capture(...)
     3. | +-testthat:::.capture(...)
     4. | | \-base::withCallingHandlers(...)
     5. | \-rlang::eval_bare(quo_get_expr(.quo), quo_get_env(.quo))
     6. +-discrim_regularized() %>% set_engine("monday")
     7. \-parsnip::set_engine(., "monday")
     8. \-parsnip:::check_spec_mode_engine_val(...)
    
     [ FAIL 7 | WARN 0 | SKIP 0 | PASS 676 ]
     Error: Test failures
     Execution halted
Flavor: r-oldrel-windows-ix86+x86_64

Package embed

Current CRAN status: NOTE: 12, OK: 2

Version: 0.1.4
Check: LazyData
Result: NOTE
     'LazyData' is specified without a 'data' directory
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-devel-windows-x86_64, r-devel-windows-x86_64-gcc10-UCRT, r-patched-linux-x86_64, r-patched-solaris-x86, r-release-linux-x86_64, r-release-macos-arm64, r-release-macos-x86_64, r-release-windows-ix86+x86_64

Package finetune

Current CRAN status: ERROR: 1, NOTE: 7, OK: 6

Version: 0.1.0
Check: dependencies in R code
Result: NOTE
    Namespaces in Imports field not imported from:
     ‘ranger’ ‘yardstick’
     All declared Imports should be used.
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-patched-solaris-x86, r-release-macos-arm64, r-release-macos-x86_64, r-oldrel-macos-x86_64

Version: 0.0.1
Check: dependencies in R code
Result: NOTE
    Namespace in Imports field not imported from: 'yardstick'
     All declared Imports should be used.
Flavor: r-devel-windows-x86_64-gcc10-UCRT

Version: 0.0.1
Check: LazyData
Result: NOTE
     'LazyData' is specified without a 'data' directory
Flavor: r-devel-windows-x86_64-gcc10-UCRT

Version: 0.0.1
Check: tests
Result: ERROR
     Running 'helpers.R' [6s]
     Running 'spelling.R' [0s]
     Running 'testthat.R' [183s]
    Running the tests in 'tests/testthat.R' failed.
    Complete output:
     > library(testthat)
     > library(finetune)
     Loading required package: tune
     >
     > test_check("finetune")
    
     Attaching package: 'rsample'
    
     The following object is masked from 'package:testthat':
    
     matches
    
    
     Attaching package: 'dplyr'
    
     The following object is masked from 'package:testthat':
    
     matches
    
     The following objects are masked from 'package:stats':
    
     filter, lag
    
     The following objects are masked from 'package:base':
    
     intersect, setdiff, setequal, union
    
     Loading required package: Matrix
     For binary classification, the first factor level is assumed to be the event.
     Use the argument `event_level = "second"` to alter this as needed.
    
     Attaching package: 'workflows'
    
     The following object is masked from 'package:tune':
    
     extract_recipe
    
     ! Fold3, Repeat1: preprocessor 1/1, model 1/8 (predictions): `pull_workflow_fit()` was dep...
     ! Fold3, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold3, Repeat1: preprocessor 1/1, model 2/8 (predictions): `pull_workflow_fit()` was dep...
     ! Fold3, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold3, Repeat1: preprocessor 1/1, model 3/8 (predictions): `pull_workflow_fit()` was dep...
     ! Fold3, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold3, Repeat1: preprocessor 1/1, model 4/8 (predictions): `pull_workflow_fit()` was dep...
     ! Fold3, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold3, Repeat1: preprocessor 1/1, model 5/8 (predictions): `pull_workflow_fit()` was dep...
     ! Fold3, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold3, Repeat1: preprocessor 1/1, model 6/8 (predictions): `pull_workflow_fit()` was dep...
     ! Fold3, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold3, Repeat1: preprocessor 1/1, model 7/8 (predictions): `pull_workflow_fit()` was dep...
     ! Fold3, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold3, Repeat1: preprocessor 1/1, model 8/8 (predictions): `pull_workflow_fit()` was dep...
     ! Fold3, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold4, Repeat1: preprocessor 1/1, model 1/8 (predictions): `pull_workflow_fit()` was dep...
     ! Fold4, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold4, Repeat1: preprocessor 1/1, model 2/8 (predictions): `pull_workflow_fit()` was dep...
     ! Fold4, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold4, Repeat1: preprocessor 1/1, model 3/8 (predictions): `pull_workflow_fit()` was dep...
     ! Fold4, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold4, Repeat1: preprocessor 1/1, model 4/8 (predictions): `pull_workflow_fit()` was dep...
     ! Fold4, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold4, Repeat1: preprocessor 1/1, model 5/8 (predictions): `pull_workflow_fit()` was dep...
     ! Fold4, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold4, Repeat1: preprocessor 1/1, model 6/8 (predictions): `pull_workflow_fit()` was dep...
     ! Fold4, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold4, Repeat1: preprocessor 1/1, model 7/8 (predictions): `pull_workflow_fit()` was dep...
     ! Fold4, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold4, Repeat1: preprocessor 1/1, model 8/8 (predictions): `pull_workflow_fit()` was dep...
     ! Fold4, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold2, Repeat1: preprocessor 1/1, model 1/8 (predictions): `pull_workflow_fit()` was dep...
     ! Fold2, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold2, Repeat1: preprocessor 1/1, model 2/8 (predictions): `pull_workflow_fit()` was dep...
     ! Fold2, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold2, Repeat1: preprocessor 1/1, model 3/8 (predictions): `pull_workflow_fit()` was dep...
     ! Fold2, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold2, Repeat1: preprocessor 1/1, model 4/8 (predictions): `pull_workflow_fit()` was dep...
     ! Fold2, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold2, Repeat1: preprocessor 1/1, model 5/8 (predictions): `pull_workflow_fit()` was dep...
     ! Fold2, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold2, Repeat1: preprocessor 1/1, model 6/8 (predictions): `pull_workflow_fit()` was dep...
     ! Fold2, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold2, Repeat1: preprocessor 1/1, model 7/8 (predictions): `pull_workflow_fit()` was dep...
     ! Fold2, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold2, Repeat1: preprocessor 1/1, model 8/8 (predictions): `pull_workflow_fit()` was dep...
     ! Fold2, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold1, Repeat1: preprocessor 1/1, model 1/7 (predictions): `pull_workflow_fit()` was dep...
     ! Fold1, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold1, Repeat1: preprocessor 1/1, model 2/7 (predictions): `pull_workflow_fit()` was dep...
     ! Fold1, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold1, Repeat1: preprocessor 1/1, model 3/7 (predictions): `pull_workflow_fit()` was dep...
     ! Fold1, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold1, Repeat1: preprocessor 1/1, model 4/7 (predictions): `pull_workflow_fit()` was dep...
     ! Fold1, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold1, Repeat1: preprocessor 1/1, model 5/7 (predictions): `pull_workflow_fit()` was dep...
     ! Fold1, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold1, Repeat1: preprocessor 1/1, model 6/7 (predictions): `pull_workflow_fit()` was dep...
     ! Fold1, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold1, Repeat1: preprocessor 1/1, model 7/7 (predictions): `pull_workflow_fit()` was dep...
     ! Fold1, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold5, Repeat1: preprocessor 1/1, model 1/7 (predictions): `pull_workflow_fit()` was dep...
     ! Fold5, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold5, Repeat1: preprocessor 1/1, model 2/7 (predictions): `pull_workflow_fit()` was dep...
     ! Fold5, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold5, Repeat1: preprocessor 1/1, model 3/7 (predictions): `pull_workflow_fit()` was dep...
     ! Fold5, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold5, Repeat1: preprocessor 1/1, model 4/7 (predictions): `pull_workflow_fit()` was dep...
     ! Fold5, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold5, Repeat1: preprocessor 1/1, model 5/7 (predictions): `pull_workflow_fit()` was dep...
     ! Fold5, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold5, Repeat1: preprocessor 1/1, model 6/7 (predictions): `pull_workflow_fit()` was dep...
     ! Fold5, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold5, Repeat1: preprocessor 1/1, model 7/7 (predictions): `pull_workflow_fit()` was dep...
     ! Fold5, Repeat1: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold4, Repeat2: preprocessor 1/1, model 1/7 (predictions): `pull_workflow_fit()` was dep...
     ! Fold4, Repeat2: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold4, Repeat2: preprocessor 1/1, model 2/7 (predictions): `pull_workflow_fit()` was dep...
     ! Fold4, Repeat2: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold4, Repeat2: preprocessor 1/1, model 3/7 (predictions): `pull_workflow_fit()` was dep...
     ! Fold4, Repeat2: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold4, Repeat2: preprocessor 1/1, model 4/7 (predictions): `pull_workflow_fit()` was dep...
     ! Fold4, Repeat2: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold4, Repeat2: preprocessor 1/1, model 5/7 (predictions): `pull_workflow_fit()` was dep...
     ! Fold4, Repeat2: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold4, Repeat2: preprocessor 1/1, model 6/7 (predictions): `pull_workflow_fit()` was dep...
     ! Fold4, Repeat2: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold4, Repeat2: preprocessor 1/1, model 7/7 (predictions): `pull_workflow_fit()` was dep...
     ! Fold4, Repeat2: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold2, Repeat2: preprocessor 1/1, model 1/6 (predictions): `pull_workflow_fit()` was dep...
     ! Fold2, Repeat2: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold2, Repeat2: preprocessor 1/1, model 2/6 (predictions): `pull_workflow_fit()` was dep...
     ! Fold2, Repeat2: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold2, Repeat2: preprocessor 1/1, model 3/6 (predictions): `pull_workflow_fit()` was dep...
     ! Fold2, Repeat2: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold2, Repeat2: preprocessor 1/1, model 4/6 (predictions): `pull_workflow_fit()` was dep...
     ! Fold2, Repeat2: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold2, Repeat2: preprocessor 1/1, model 5/6 (predictions): `pull_workflow_fit()` was dep...
     ! Fold2, Repeat2: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold2, Repeat2: preprocessor 1/1, model 6/6 (predictions): `pull_workflow_fit()` was dep...
     ! Fold2, Repeat2: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold1, Repeat2: preprocessor 1/1, model 1/3 (predictions): `pull_workflow_fit()` was dep...
     ! Fold1, Repeat2: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold1, Repeat2: preprocessor 1/1, model 2/3 (predictions): `pull_workflow_fit()` was dep...
     ! Fold1, Repeat2: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold1, Repeat2: preprocessor 1/1, model 3/3 (predictions): `pull_workflow_fit()` was dep...
     ! Fold1, Repeat2: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold3, Repeat2: preprocessor 1/1, model 1/3 (predictions): `pull_workflow_fit()` was dep...
     ! Fold3, Repeat2: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold3, Repeat2: preprocessor 1/1, model 2/3 (predictions): `pull_workflow_fit()` was dep...
     ! Fold3, Repeat2: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold3, Repeat2: preprocessor 1/1, model 3/3 (predictions): `pull_workflow_fit()` was dep...
     ! Fold3, Repeat2: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold5, Repeat2: preprocessor 1/1, model 1/3 (predictions): `pull_workflow_fit()` was dep...
     ! Fold5, Repeat2: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold5, Repeat2: preprocessor 1/1, model 2/3 (predictions): `pull_workflow_fit()` was dep...
     ! Fold5, Repeat2: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
     ! Fold5, Repeat2: preprocessor 1/1, model 3/3 (predictions): `pull_workflow_fit()` was dep...
     ! Fold5, Repeat2: internal: `pull_workflow_spec()` was deprecated in workflows 0.2.3.
     Plea...
    
     Attaching package: 'discrim'
    
     The following object is masked from 'package:dials':
    
     smoothness
    
     == Skipped tests ===============================================================
     * On CRAN (13)
    
     == Failed tests ================================================================
     -- Failure (test-anova-filter.R:131:3): top-level anova filter interfaces ------
     `expect_error(...)` produced warnings, messages.
    
     [ FAIL 1 | WARN 48 | SKIP 13 | PASS 181 ]
     Error: Test failures
     Execution halted
Flavor: r-oldrel-windows-ix86+x86_64

Package modeldata

Current CRAN status: NOTE: 7, OK: 7

Version: 0.1.1
Check: data for non-ASCII characters
Result: NOTE
     Note: found 313 marked UTF-8 strings
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-devel-windows-x86_64-gcc10-UCRT, r-patched-solaris-x86, r-release-macos-arm64, r-release-macos-x86_64, r-oldrel-macos-x86_64

Version: 0.1.1
Check: installed package size
Result: NOTE
     installed size is 5.5Mb
     sub-directories of 1Mb or more:
     data 5.3Mb
Flavor: r-patched-solaris-x86

Package modeldb

Current CRAN status: OK: 14

Package parsnip

Current CRAN status: NOTE: 1, OK: 13

Version: 0.1.7
Check: Rd cross-references
Result: NOTE
    Undeclared packages ‘glmnet’, ‘rstan’, ‘rstanarm’, ‘discrim’, ‘devtools’, ‘broom’ in Rd xrefs
Flavor: r-devel-linux-x86_64-fedora-clang

Package plsmod

Current CRAN status: ERROR: 1, NOTE: 11, OK: 2

Version: 0.1.1
Check: LazyData
Result: NOTE
     'LazyData' is specified without a 'data' directory
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-devel-windows-x86_64, r-devel-windows-x86_64-gcc10-UCRT, r-patched-linux-x86_64, r-patched-solaris-x86, r-release-linux-x86_64, r-release-macos-x86_64, r-release-windows-ix86+x86_64

Version: 0.1.1
Check: package dependencies
Result: ERROR
    Package required but not available: ‘mixOmics’
    
    See section ‘The DESCRIPTION file’ in the ‘Writing R Extensions’
    manual.
Flavor: r-release-macos-arm64

Package poissonreg

Current CRAN status: OK: 14

Package recipes

Current CRAN status: NOTE: 1, OK: 13

Version: 0.1.16
Check: Rd cross-references
Result: NOTE
    Undeclared packages ‘workflows’, ‘hardhat’ in Rd xrefs
Flavor: r-devel-linux-x86_64-fedora-clang

Package rules

Current CRAN status: ERROR: 4, NOTE: 8, OK: 2

Version: 0.1.1
Check: package dependencies
Result: NOTE
    Package suggested but not available for checking: 'xrf'
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc

Version: 0.1.1
Check: LazyData
Result: NOTE
     'LazyData' is specified without a 'data' directory
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-devel-windows-x86_64, r-devel-windows-x86_64-gcc10-UCRT, r-patched-linux-x86_64, r-patched-solaris-x86, r-release-linux-x86_64, r-release-macos-arm64, r-release-macos-x86_64, r-release-windows-ix86+x86_64

Version: 0.1.1
Check: examples
Result: ERROR
    Running examples in 'rules-Ex.R' failed
    The error most likely occurred in:
    
    > base::assign(".ptime", proc.time(), pos = "CheckExEnv")
    > ### Name: rule_fit
    > ### Title: General Interface for RuleFit Models
    > ### Aliases: rule_fit update.rule_fit
    >
    > ### ** Examples
    >
    > rule_fit()
    RuleFit Model Specification (unknown)
    
    Computational engine: xrf
    
    > # Parameters can be represented by a placeholder:
    > rule_fit(trees = 7)
    RuleFit Model Specification (unknown)
    
    Main Arguments:
     trees = 7
    
    Computational engine: xrf
    
    >
    > # ------------------------------------------------------------------------------
    >
    > set.seed(6907)
    > rule_fit_rules <-
    + rule_fit(trees = 3, penalty = 0.1) %>%
    + set_mode("classification") %>%
    + fit(Species ~ ., data = iris)
    Error: This engine requires some package installs: 'xrf'
    Backtrace:
     x
     1. +-`%>%`(...)
     2. +-generics::fit(., Species ~ ., data = iris)
     3. \-parsnip::fit.model_spec(., Species ~ ., data = iris)
     4. \-parsnip:::check_installs(object)
    Execution halted
Flavor: r-devel-linux-x86_64-debian-clang

Version: 0.1.1
Check: re-building of vignette outputs
Result: WARN
    Error(s) in re-building vignettes:
     ...
    --- re-building 'Cubist-and-RuleFit.Rmd' using rmarkdown
    Quitting from lines 189-197 (Cubist-and-RuleFit.Rmd)
    Error: processing vignette 'Cubist-and-RuleFit.Rmd' failed with diagnostics:
    This engine requires some package installs: 'xrf'
    --- failed re-building 'Cubist-and-RuleFit.Rmd'
    
    SUMMARY: processing the following file failed:
     'Cubist-and-RuleFit.Rmd'
    
    Error: Vignette re-building failed.
    Execution halted
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc

Version: 0.1.1
Check: examples
Result: ERROR
    Running examples in ‘rules-Ex.R’ failed
    The error most likely occurred in:
    
    > base::assign(".ptime", proc.time(), pos = "CheckExEnv")
    > ### Name: rule_fit
    > ### Title: General Interface for RuleFit Models
    > ### Aliases: rule_fit update.rule_fit
    >
    > ### ** Examples
    >
    > rule_fit()
    RuleFit Model Specification (unknown)
    
    Computational engine: xrf
    
    > # Parameters can be represented by a placeholder:
    > rule_fit(trees = 7)
    RuleFit Model Specification (unknown)
    
    Main Arguments:
     trees = 7
    
    Computational engine: xrf
    
    >
    > # ------------------------------------------------------------------------------
    >
    > set.seed(6907)
    > rule_fit_rules <-
    + rule_fit(trees = 3, penalty = 0.1) %>%
    + set_mode("classification") %>%
    + fit(Species ~ ., data = iris)
    Error: This engine requires some package installs: 'xrf'
    Backtrace:
     █
     1. ├─`%>%`(...)
     2. ├─generics::fit(., Species ~ ., data = iris)
     3. └─parsnip::fit.model_spec(., Species ~ ., data = iris)
     4. └─parsnip:::check_installs(object)
    Execution halted
Flavor: r-devel-linux-x86_64-debian-gcc

Version: 0.1.1
Check: examples
Result: ERROR
    Running examples in ‘rules-Ex.R’ failed
    The error most likely occurred in:
    
    > ### Name: rule_fit
    > ### Title: General Interface for RuleFit Models
    > ### Aliases: rule_fit update.rule_fit
    >
    > ### ** Examples
    >
    > rule_fit()
    RuleFit Model Specification (unknown)
    
    Computational engine: xrf
    
    > # Parameters can be represented by a placeholder:
    > rule_fit(trees = 7)
    RuleFit Model Specification (unknown)
    
    Main Arguments:
     trees = 7
    
    Computational engine: xrf
    
    >
    > # ------------------------------------------------------------------------------
    >
    > set.seed(6907)
    > rule_fit_rules <-
    + rule_fit(trees = 3, penalty = 0.1) %>%
    + set_mode("classification") %>%
    + fit(Species ~ ., data = iris)
    Error: This engine requires some package installs: 'xrf'
    Backtrace:
     █
     1. ├─`%>%`(...)
     2. ├─generics::fit(., Species ~ ., data = iris)
     3. └─parsnip::fit.model_spec(., Species ~ ., data = iris)
     4. └─parsnip:::check_installs(object)
    Execution halted
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc

Version: 0.1.1
Check: re-building of vignette outputs
Result: WARN
    Error(s) in re-building vignettes:
    --- re-building ‘Cubist-and-RuleFit.Rmd’ using rmarkdown
    Quitting from lines 189-197 (Cubist-and-RuleFit.Rmd)
    Error: processing vignette 'Cubist-and-RuleFit.Rmd' failed with diagnostics:
    This engine requires some package installs: 'xrf'
    --- failed re-building ‘Cubist-and-RuleFit.Rmd’
    
    SUMMARY: processing the following file failed:
     ‘Cubist-and-RuleFit.Rmd’
    
    Error: Vignette re-building failed.
    Execution halted
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc

Package tidymodels

Current CRAN status: NOTE: 7, OK: 7

Version: 0.1.3
Check: dependencies in R code
Result: NOTE
    Namespaces in Imports field not imported from:
     ‘modeldata’ ‘workflowsets’
     All declared Imports should be used.
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-devel-windows-x86_64-gcc10-UCRT, r-patched-solaris-x86, r-release-macos-arm64, r-release-macos-x86_64, r-oldrel-macos-x86_64

Package tidyposterior

Current CRAN status: OK: 14

Package tidypredict

Current CRAN status: OK: 14

Package tune

Current CRAN status: ERROR: 1, NOTE: 1, OK: 12

Version: 0.1.6
Check: package dependencies
Result: NOTE
    Imports includes 21 non-default packages.
    Importing from so many packages makes the package vulnerable to any of
    them becoming unavailable. Move as many as possible to Suggests and
    use conditionally.
Flavor: r-devel-linux-x86_64-fedora-clang

Version: 0.1.5
Check: tests
Result: ERROR
     Running 'helper-objects.R' [7s]
     Running 'spelling.R' [0s]
     Running 'testthat.R' [6s]
    Running the tests in 'tests/helper-objects.R' failed.
    Complete output:
     > library(tune)
     Registered S3 method overwritten by 'tune':
     method from
     required_pkgs.model_spec parsnip
     > library(recipes)
     Loading required package: dplyr
    
     Attaching package: 'dplyr'
    
     The following objects are masked from 'package:stats':
    
     filter, lag
    
     The following objects are masked from 'package:base':
    
     intersect, setdiff, setequal, union
    
    
     Attaching package: 'recipes'
    
     The following object is masked from 'package:stats':
    
     step
    
     > library(parsnip)
     > library(rsample)
     > library(workflows)
    
     Attaching package: 'workflows'
    
     The following object is masked from 'package:tune':
    
     extract_recipe
    
     > library(dplyr)
     > library(tidyr)
     > library(kernlab)
     > library(dials)
     Loading required package: scales
    
     Attaching package: 'scales'
    
     The following object is masked from 'package:kernlab':
    
     alpha
    
     > library(yardstick)
     For binary classification, the first factor level is assumed to be the event.
     Use the argument `event_level = "second"` to alter this as needed.
     >
     > data("Chicago", package = "dials")
     >
     > # ------------------------------------------------------------------------------
     >
     > spline_rec <-
     + recipe(ridership ~ ., data = head(Chicago)) %>%
     + step_date(date) %>%
     + step_holiday(date) %>%
     + step_rm(date, ends_with("away")) %>%
     + step_knnimpute(all_predictors(), neighbors = tune("imputation")) %>%
     + step_other(all_nominal(), threshold = tune()) %>%
     + step_dummy(all_nominal()) %>%
     + step_normalize(all_predictors()) %>%
     + step_bs(all_predictors(), deg_free = tune(), degree = tune())
     Warning message:
     `step_knnimpute()` was deprecated in recipes 0.1.16.
     Please use `step_impute_knn()` instead.
     >
     > bare_rec <-
     + recipe(ridership ~ ., data = head(Chicago))
     >
     > rm_rec <-
     + recipe(ridership ~ ., data = head(Chicago)) %>%
     + step_rm(date, ends_with("away"))
     >
     > ununtable_rec <-
     + recipe(ridership ~ ., data = head(Chicago)) %>%
     + step_dummy(all_nominal(), naming = tune())
     >
     > # ------------------------------------------------------------------------------
     >
     > bst_model <-
     + boost_tree(mode = "classification", trees = tune("funky name \n")) %>%
     + set_engine("C5.0", rules = tune(), noGlobalPruning = TRUE)
     >
     > lm_model <-
     + linear_reg() %>%
     + set_engine("lm")
     >
     > no_engine <- linear_reg()
     >
     > weird_annotation <-
     + boost_tree(mode = "regression", trees = tune("$^%&#!")) %>%
     + set_engine("C5.0", rules = TRUE, noGlobalPruning = TRUE)
     Error: Available modes for engine C5.0 are: 'unknown', 'classification'
     Backtrace:
     x
     1. +-`%>%`(...)
     2. \-parsnip::set_engine(., "C5.0", rules = TRUE, noGlobalPruning = TRUE)
     3. \-parsnip:::check_spec_mode_engine_val(...)
     4. \-parsnip:::stop_incompatible_mode(spec_modes, eng)
     Execution halted
Flavor: r-oldrel-windows-ix86+x86_64

Package usemodels

Current CRAN status: NOTE: 13, OK: 1

Version: 0.1.0
Check: LazyData
Result: NOTE
     'LazyData' is specified without a 'data' directory
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-devel-windows-x86_64, r-devel-windows-x86_64-gcc10-UCRT, r-patched-linux-x86_64, r-patched-solaris-x86, r-release-linux-x86_64, r-release-macos-arm64, r-release-macos-x86_64, r-release-windows-ix86+x86_64

Version: 0.1.0
Check: dependencies in R code
Result: NOTE
    Namespace in Imports field not imported from: ‘cli’
     All declared Imports should be used.
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-devel-windows-x86_64-gcc10-UCRT, r-patched-solaris-x86, r-release-macos-arm64, r-release-macos-x86_64, r-oldrel-macos-x86_64

Package workflowsets

Current CRAN status: WARN: 1, OK: 13

Version: 0.1.0
Check: re-building of vignette outputs
Result: WARN
    Error(s) in re-building vignettes:
     ...
    --- re-building ‘evaluating-different-predictor-sets.Rmd’ using rmarkdown
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) not available. Falling back to R Markdown v1.
    Quitting from lines 89-127 (evaluating-different-predictor-sets.Rmd)
    Error: processing vignette 'evaluating-different-predictor-sets.Rmd' failed with diagnostics:
    polygon edge not found
    --- failed re-building ‘evaluating-different-predictor-sets.Rmd’
    
    SUMMARY: processing the following file failed:
     ‘evaluating-different-predictor-sets.Rmd’
    
    Error: Vignette re-building failed.
    Execution halted
Flavor: r-release-macos-arm64